Ipfs-update error

While trying to update from IPFS 0.7.x to IPFS 0.8.0 on linux, it gives an error about permission denied. It worked fine on one server, but not on another. Here are the commands used for updating, I wonder if the issue is with the ipfs-update tool? Any help appreciated:

service ipfs stop
wget https://dist.ipfs.io/ipfs-update/v1.6.0/ipfs-update_v1.6.0_linux-amd64.tar.gz
tar -zxvf ipfs-update_v1.6.0_linux-amd64.tar.gz
cd ipfs-update/
./install.sh
ipfs-update install latest

fetching go-ipfs version v0.8.0
binary downloaded, verifying…
install failed, reverting changes…
ERROR: error initializing with new binary: fork/exec /tmp/ipfs-update727158951/ipfs-new: permission denied:

Can you check the permissions and ownership on /tmp/ipfs-update727158951/ipfs-new.

What are they? Should they be something different? Why are they like that? I suspect answers might be specific to your system.

The permissions look like this:
ls -l /tmp/ipfs-update727158951/ipfs-new
-rwxr-xr-x 1 root root 59847352 Feb 21 05:08 /tmp/ipfs-update727158951/ipfs-new

The permissions on the non-working server seem to be the same for the other server where the update worked on.