IPFS keeps killing my router

Hi,

I’m new to IPFS. I have installed it on a couple computers that I have at home (a laptop and also a desktop that always stays on) and for some reason it keeps killing my router: suddenly my Internet connection stops working, and doesn’t work again until I restart the router.

This happens randomly, even if I’m not actively using IPFS, as long as the daemon is running. I have tried to use this guide to set the profile to “low power”, but the problem still happens. It does seem to happen less often, though.

Is there anything I can do to stop it from happening at all?

Thanks!

1 Like

Buy a new router. My IPFS daemon runs 600+ constantly changing connections which is more than many entry-level routers can handle.

1 Like

See Writeup of router kill issue · Issue #3320 · ipfs/go-ipfs · GitHub. Advised is to disable quic, but if lowpower crashes your router, then it is going to be hard to make your router happy.

in addition, to disable QUIC I discovered the following on several old routers: when the Swarm section has the wrong AddrFilters array setup, it could lead to IPFS daemon sending to the router the connection requests for not allowed IP ranges like 192.168.0.0/16 or 10.0.0.0/8. These connections are hang up by the router without both answer and TTL, so the router’s connections pool overflows.

1 Like

@davidprieto do you mind telling us the model of impacted router you had?
We want to buy the same model for testing.

(This ask goes also to everyone else with similar problem).

@davidprieto someone on the discord think to have found the issue, I would like to see if that confirms.

Can you try running LIBP2P_TCP_REUSEPORT=false ipfs daemon that will disable the TCP ReusePort feature.