Help, please. Error: no valid addresses were provided for transports [TCP,WebSockets,Circuit] After upgrading from ^0.49.0", to "^0.54.4"

I am trying to connect an ipfs-js instance running on a browser to another running on Node (the Node one is planned to be used as a pinner). Both are on my local machine for now.

Usually, I was able to force the peer connection between the browser instance one and the pinner adding the pinner multiaddress in the Bootstrap config of the browser instance. Not any more after updaring to ipfs v0.54.4.

The pinner instance (using the default empty config) output this after boot:

Swarm listening on /ip4/127.0.0.1/tcp/4002/p2p/QmTtpTTBJiJnM5UKQsAfnFHC4URVVt2eX2V3CQAQ1GGA6d

And I then use this on the browser configuration as follows (manually changing 4002 for 4003/ws, a trick Mark from OrbitDB taught me :)) :

{ 
Bootstrap: ["/dns4/localhost/tcp/4003/ws/p2p/QmZqoT5wRxSBEhkQrD34s4Rb7in6vRR3ceKhyKbCvVDbgb"']  
}

I then try to connect to the pinner peer from the browser with

ipfs.swarm.connect("/dns4/localhost/tcp/4003/ws/p2p/QmZqoT5wRxSBEhkQrD34s4Rb7in6vRR3ceKhyKbCvVDbgb").then((r) => {
      this.logger.log(`Connected to peer`, r);
    });

But I get the error

Error: No transport available for address /dns4/localhost/tcp/4003/ws/p2p/QmTtpTTBJiJnM5UKQsAfnFHC4URVVt2eX2V3CQAQ1GGA6d

I also tried running a signaling and connecting both instances to it. I’d run the server with

star-signal --port=13579 --host=127.0.0.1

And configuring the Addresses: Swarm: ["/ip4/127.0.0.1/tcp/13579/ws/p2p-webrtc-star/"] option, but only the browser instance gets to connect, while the one running on Node shows a similar error as before:

Error: no valid addresses were provided for transports [TCP,WebSockets,Circuit]