Github -> Issues -> Here -> Search -> Gateway -> ipfs.io -> dweb.link

No, the wifi dropped out. Just restarted the wifi and peers are returning. Just tried reprovide commend and it says it’s already running.

K, it’s back, on a different port. Also, you are using an outdated version of the software, you should update to the latest (you are using 0.8, and 0.12 is the current one).

I found the ipfs-update utility and ran it from a directory under downloads. All the instructions said was to not put it on the path, but no place specific. It produced an error.

:~/Downloads/ipfs-update$ ipfs-update install v0.12.0
fetching go-ipfs version v0.12.0
binary downloaded, verifying…
install failed, reverting changes…
ERROR: test refs list: expected to see QmTFJQ68kaArzsqz2Yjg1yMyEA5TXTfNw6d9wSFhxtBxz2 in the local refs!

The node was and is offline. IPFS is installed in .ipfs folder under my user

Hrm, it really depends on your OS and which way you installed IPFS initially. I’m not sure you can use ipfs-update in every case (I’ve never used it myself). If you are not installing on a server, the simplest way is to use IPFS Desktop.

I’m running go-ipfs with Ubuntu LTS latest and let it install in the default location. I only have Desktop installed on my old Win7 PC and I do like its update feature. Wish go-ipfs was as easy to update.

I’m going to try running ipfs-update from the .ipfs directory. That produced the same error.

the simplest way to replace it is to shut down the currently running instance (looks like that already happened), download the appropriate binary from:

check where your current install is with:

which ipfs

remove and replace the binary from that location (you may have to use sudo), run:

ipfs --version

to verify it’s installed properly, and then launch the daemon the usual way you do it.

P.S. the first time you run 0.12, it will migrate your repo, which may take a while if you have a lot in it.

P.P.S Here is the official version of what I just explained:

That worked. Many thanks. Everything now look okay?

Looks good from here, and running 0.12! :slight_smile:

Appreciate all your help. Time for a cool beverage and a movie :sunglasses:

Are there any ports other than 4001 which my firewall should allow from outside to optimize go-ipfs for access to the websites I publish on IPFS? That includes all the ones listed with a publishing program link at
ipns://k2k4r8n098cwalcc7rdntd19nsjyzh6rku1hvgsmkjzvnw582mncc4b4/IPFS_WebsitesDirectory.html

Your node appears to use a random port every time you restart it. It is probably using UPnP to acquire a port instead of using 4001. Check your config at Swarm.DisableNatPortMap (I have mine set to true, so it doesn’t do that). If that’s the case, you actually don’t need to set up a static port forwarding (that’s what UPnP does for you). If you’d rather use static port forwarding, set that to true and port map UDP 4001 to 192.168.33.135:4001 and TCP 4001 to 192.168.33.135:4001, then make sure you are still reachable. Also, make sure that Reprovider.Strategy is set to “all”.

Swarm.DisableNatPortMap was false and now is true
Reprovider.Strategy was already set to “all”
Static IP .135 was already set on the node PC
Restarted the daemon after the config changes.
Port forwarding was already TCP and now also UDP.
Will reboot the node PC as soon as the current publish completes.

Many many thanks

The sites already seem to be responding much better, even without the node reboot.

I don’t see your node anymore, something is wrong with its advertising. Type “ipfs id” at the terminal and see which addresses it’s currently advertising, and make sure it includes both public addresses.

It is now advertising some addresses, but none of them are working:

> ipfs id 12D3KooWHWen2dsu4QWJE7srfSFduVPKTnGQ8jbx5MtG7iQc7YWD
Error: failed to dial 12D3KooWHWen2dsu4QWJE7srfSFduVPKTnGQ8jbx5MtG7iQc7YWD:
  * [/ip4/104.156.24.117/tcp/54136] dial tcp4 104.156.24.117:54136: connect: connection refused
  * [/ip6/64:ff9b::689c:1875/tcp/54136] dial tcp6 [::]:4001->[64:ff9b::689c:1875]:54136: i/o timeout
  * [/ip4/104.156.24.117/udp/54136/quic] timeout: no recent network activity
  * [/ip4/104.156.24.117/udp/4001/quic] timeout: no recent network activity
> nc 104.156.24.117 4001
>

I even tried to netcat into TCP 4001, and that doesn’t respond either. So, Your node is once again unreachable and needs some tlc…

It looks like the internet connection may have dropped for a few minutes a little bit ago.
ipfs id on this end now shows all the TCP and UDC connections without any errors or warnings

Still getting the same results, I don’t think either of your 2 port forwards are actually working at all. If you can’t get them to work, you should re-enable UPnP, which will make your node reachable again.

For some reason, after the internet interruption the peer count never recovered. Just restarted the daemon. Peer count is recovering and the sites on IPFS seem to be responding again.

But what about your inbound count (I still can’t connect)?

Inbound was good before my nap with a large number. Internet drop out seems to have knocked the daemon down since then with only a couple remaining inbound. Having an ice storm today and the internet is up and down. Just restarted the daemon again.