Getting an error while trying to access webui

ERROR core/serve: ipfs resolve -r /ipfs/QmPhnvn747LqwPYMJmQVorMaGbMSgA7mRRoyyZYz3DoZRQ/: Failed to get block for QmPhnvn747LqwPYMJmQVorMaGbMSgA7mRRoyyZYz3DoZRQ: context canceled gateway_handler.go:548

Could anybody please let me know why this is happening after I upgraded my ipfs?

2 Likes

What method did you use to upgrade IPFS? Could you post the output of ipfs diag sys?

I’m assuming that you’re trying to access the webUI using a URL like this:
http://localhost:5001/ipfs/QmPhnvn747LqwPYMJmQVorMaGbMSgA7mRRoyyZYz3DoZRQ/#/

edit: http://localhost:5001/webui is the correct way to access the web UI.

Faced with the same error. How do I get into Webui
QmPhnvn747LqwPYMJmQVorMaGbMSgA7mRRoyyZYz3DoZRQ

bash-4.2# 13:00:53.960 ERROR core/serve: ipfs resolve -r /ipfs/QmPhnvn747LqwPYMJmQVorMaGbMSgA7mRRoyyZYz3DoZRQ/locale/webui-ru.json: no link named “webui-ru.json” under Qmc6bAsXTFFdvV3RoLuf6jjV3jzsRLntfsivWQZ75s8QaL gateway_handler.go:548

bash-4.2# ipfs version
ipfs version 0.4.9

bash-4.2# ipfs diag sys
{“diskinfo”:{“free_space”:39386542080,“fstype”:“1481003842”,“total_space”:39386542080},“environment”:{“GOPATH”:"",“IPFS_PATH”:""},“ipfs_commit”:"",“ipfs_version”:“0.4.9”,“memory”:{“swap”:0,“virt”:563244000},“net”:{“interface_addresses”:["/ip4/127.0.0.1","/ip4/192.168.0.221","/ip6/::1","/ip6/fe80::5054:ff:fe64:84fa","/ip6/fcfd:ff98:e27c:82de:57b5:bbde:3864:4d57"],“online”:true},“runtime”:{“arch”:“amd64”,“compiler”:“gc”,“gomaxprocs”:2,“numcpu”:2,“numgoroutines”:2224,“os”:“linux”,“version”:“go1.8.1”}}

bash-4.2# ipfs resolve -r /ipfs/QmPhnvn747LqwPYMJmQVorMaGbMSgA7mRRoyyZYz3DoZRQ
/ipfs/QmPhnvn747LqwPYMJmQVorMaGbMSgA7mRRoyyZYz3DoZRQ

how to get webui-ru.json or enable webui-en.json ?

It doesn’t look like a “ru” locale exists for the webui yet: https://github.com/ipfs/webui/tree/master/dist/locale

This issue on the webui repo for this issue seems to suggest that if it can’t find the correct locale it will default to english, but I’m not sure why that wouldn’t happen.

Yes, that’s the default use webui-en.json. thanks I got it.

It seems that something is broken with centos7 or lost dependencies. Selinux disable.The webui is empty and no one talks about this reason. Ipfs runing from user elizabeth. ports tcp/4001 udp/5353 open.

p.s. ~ Test launch on the laptop success. (Linux mint) When connected 127.0.0.1:5001/webui the data is filled in webui

Hi. Now I get the file webui-zh.json. But how to configure it to make things work? Thanks!