Can't access my uploaded files from ipfs gateway

#1

i installed ipfs by the recommended way “Prebuilt Package” then i run the command “ipfs init” then “ipfs daemon” which give me this
Initializing daemon…
go-ipfs version: 0.4.20-
Repo version: 7
System version: amd64/darwin
Golang version: go1.12.4
Swarm listening on /ip4/127.0.0.1/tcp/4001
Swarm listening on /ip4/192.168.1.16/tcp/4001
Swarm listening on /ip6/::1/tcp/4001
Swarm listening on /ip6/fd8c:d76:1c5c:1900:405:2bdd:89ea:4597/tcp/4001
Swarm listening on /ip6/fd8c:d76:1c5c:1900:b538:912a:1bd3:5bef/tcp/4001
Swarm listening on /p2p-circuit
Swarm announcing /ip4/127.0.0.1/tcp/4001
Swarm announcing /ip4/192.168.1.16/tcp/4001
Swarm announcing /ip6/::1/tcp/4001
Swarm announcing /ip6/fd8c:d76:1c5c:1900:405:2bdd:89ea:4597/tcp/4001
Swarm announcing /ip6/fd8c:d76:1c5c:1900:b538:912a:1bd3:5bef/tcp/4001
API server listening on /ip4/127.0.0.1/tcp/5001
WebUI: http://127.0.0.1:5001/webui
Gateway (readonly) server listening on /ip4/127.0.0.1/tcp/8080
Daemon is ready

when i upload file using ipfs add i can access it only from my local gateway but when i try to access to from https://gateway.ipfs.io/ipfs/{hash} i do not get any response
also the webUI is working fine and i get connected to a decent number of peers

my system is mac os Mojave i even tried to run ipfs on ubuntu live install still getting no response

#2

How long do you wait? I’ve had it take up to 10 minutes after requesting content from a remote gateway to actually find that content.

Additionally you may want to check your router to ensure you’re properly forwarding IPFS traffic and that you’re node is reachable via a remote node (a good way to test this is to try to establish a swarm connection on a remote node to your current node).

Another thing you can try to help speed up content is explicitly tell the network that you’re providing a particular piece of content with ipfs dht provide <cid>

1 Like
#3

i wait until it gives me connection time out,.
i’m a bit new to ipfs i don’t know how to establish a swarm connection on a remote node to my node can you please help me with that.

#4

v0.4.20 added auto relay functionality for nodes with poor connectivity. It can take a few minutes to get a relay address and it’s currently experimental, but it seems to help in some cases from what I’ve seen so far.

This can be enabled using ipfs config --json Swarm.EnableAutoRelay true.

What do you consider a decent number of peers?

#5

sometimes it reaches 800 and on average it is 400 when it’s too low it reaches 60

#6

After checking my router and configuring it to properly forward IPFS traffic and restarting my pc it finally worked thank you so much