Cannot connect to ipfs cli installed from snap

I have installed ipfs cli via snap on Ubuntu and have run ipfs init and ipfs daemon. However, I cannot get IPFS desktop to connect to my cli node. I have installed both the appimage and the ipfs-desktop snap but both report “Could not connect to the IPFS API” when I run them.

I was thinking ipfs desktop was pointing to the incorrect repository so I tried to point it at the ipfs cli snap location (for some reason the repo is created at ~/snap/ipfs/common which I’m guessing is some kind of sandboxing going on; setting IPFS_PATH has no effect on this path), but without success. the AppImage changes without issue but I still get the “Could not connect to the IPFS API” error. Trying to change the repo dir from the snap version results in a permission denied error.

My understanding is that IPFS desktop will just connect to a running node if it exists and will only install its own node if the ipfs cli daemon is not running. As an aside, I can access the ipfs daemon from a web browser using both the IPFS companion for FF and from the url localhost:5001.